Difficulties loading funding pages
Incident Report for Kraken
Resolved
A fix has been deployed. Issues that were affecting our funding pages have been resolved.
Posted 23 days ago. Sep 25, 2019 - 17:43 UTC
Identified
Our engineers have identified the issue and are currently working on a fix.
Posted 23 days ago. Sep 25, 2019 - 15:02 UTC
Investigating
We are receiving reports from clients experiencing difficulties loading the funding pages. Our developers are investigating the issue. We will provide updates as receive them.
Posted 23 days ago. Sep 25, 2019 - 14:42 UTC
This incident affected: Website.