Issue with funding pages not loading
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted May 08, 2017 - 16:52 UTC
Identified
We have an issue with deposit and withdrawal pages not loading for many clients. This is a technical issue and we have been working to resolve it as soon as possible.
Posted May 08, 2017 - 14:20 UTC