Ethereum (ETH) Funding Issues
Incident Report for Kraken
Resolved
The ETH funding delay issue has now been resolved.
Posted 3 months ago. Aug 02, 2019 - 20:02 UTC
Investigating
Ethereum (ETH) deposits and withdrawals are currently delayed. We are investigating the issue, and will provide any updates as soon as possible.
Posted 3 months ago. Aug 02, 2019 - 18:54 UTC
This incident affected: Digital Currency Funding (Ether (ETH)).