Balance Display Issue: Recent Deposits Not Showing for Some Clients

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Jan 26, 2025 - 09:46 UTC

Identified

We are aware of an issue affecting some clients where recent deposits may not reflect or display correctly in the Balance Overview. Funds remain secure and accessible for trading and funding.

The issue appears to be a visual only discrepancy, and our team is actively working to resolve it.
Posted Jan 26, 2025 - 06:02 UTC