Clear Junction - Pound Sterling (GBP) - Domestic Withdrawal Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Mar 28, 2024 - 13:21 UTC
Identified
We have identified an issue with the Clear Junction funding gateway. Withdrawals for Pound Sterling (GBP) - Domestic may be delayed at this time. All other funding methods are operating normally. We are working diligently to resolve the issue and will keep you updated.
Posted Mar 28, 2024 - 12:19 UTC
This incident affected: Payment Methods (Pound Sterling (GBP) - Domestic).