Degraded Performance on Kraken Pro Web - Trading and Balances View Temporarily Blocked for Some Users

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Feb 22, 2026 - 15:04 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 22, 2026 - 13:22 UTC

Investigating

We are investigating an issue affecting Kraken Pro Web where some users may experience delays loading balances and portfolio data.

During this time, affected users may be temporarily unable to place Spot or Futures trades while balances are loading. The issue is intermittent, and functionality is typically restored after refreshing the page. Our engineering teams are actively investigating the root cause. We will provide further updates as more information becomes available.
Posted Feb 22, 2026 - 13:11 UTC
This incident affected: Website.