Cryptocurrency Funding Delays for Clients in Germany
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Oct 23, 2024 - 06:04 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 22, 2024 - 09:36 UTC
Investigating
We are currently investigating a technical issue affecting cryptocurrency deposits and withdrawals for our clients in Germany. As a result, some transactions may be experiencing delays. All other funding methods are operating normally. We are working diligently to resolve the issue. Further updates will be provided as more information becomes available.
Posted Oct 22, 2024 - 08:27 UTC