Card Payments Issue
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jul 29, 2021 - 10:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 29, 2021 - 09:50 UTC
Investigating
Some users may be unable to make purchases using a debit/credit card. All other funding methods remain available. We are investigating the issue.
Posted Jul 29, 2021 - 09:36 UTC
This incident affected: Payment Methods (Euro (EUR) - Debit / Credit Cards).