Scheduled Maintenance - Krak Card

Scheduled for Apr 15, 09:00 - 09:30 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 14, 2026 - 20:00 UTC

Scheduled

We are performing scheduled maintenance on our Krak card infrastructure during this time.
No outage is expected. If any issues arise, some clients may briefly experience delays to card payment notifications, digital wallet alerts, and OTP codes for card provisioning.
We will update this page if anything changes.
Posted Apr 14, 2026 - 17:16 UTC
This scheduled maintenance affects: Krak Card.