Issue with displaying Futures balances and total portfolio value in Kraken Pro App

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Aug 11, 2025 - 10:58 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 08, 2025 - 14:11 UTC

Update

We are continuing to investigate this issue. Trading continues to remain fully operational. Further updates will be shared as available.
Posted Aug 07, 2025 - 16:24 UTC

Investigating

We are currently investigating an issue impacting the display of Futures balances and positions in the Kraken Pro mobile app. As a result, total portfolio value may also be inaccurate for affected users. Trading remains fully operational. Further updates will be shared as available..
Posted Aug 07, 2025 - 11:36 UTC
This incident affected: Mobile Applications.