Signet Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Sep 14, 2021 - 15:45 UTC
Monitoring
The issue has been resolved by Signature Bank, deposits and withdrawals are operational again. We are monitoring for any further issues.
Posted Sep 14, 2021 - 14:15 UTC
Investigating
Signature Bank is investigating an issue with Signet Funding. Deposits and withdrawals are working intermittently. There's no ETA at the moment, but we will provide any updates as soon as possible.
Posted Sep 14, 2021 - 09:08 UTC
This incident affected: Payment Methods (US Dollar (USD) - Domestic).