Argentine Peso (ARS) Funding Delays

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted May 19, 2026 - 23:08 UTC

Identified

We are aware of an issue with PayAmigo, that is affecting Argentine Peso (ARS) funding.
As a result, users may be unable to deposit or withdraw ARS across all Kraken products.
All other funding methods are operating normally. We will provide updates as soon as more information becomes available.
Posted May 19, 2026 - 17:36 UTC
This incident affected: Payment Methods (Argentine Peso (ARS) - Domestic).