Litecoin (LTC) Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Mar 27, 2023 - 20:48 UTC
Investigating
We're investigating an issue with the Litecoin (LTC) funding gateway. Deposits and withdrawals are currently delayed. We will provide any updates as soon as possible.
Posted Mar 27, 2023 - 20:30 UTC
This incident affected: Digital Currency Funding (Litecoin (LTC)).