Mog Coin (Mog) balances displayed inaccurately for some clients.
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Feb 03, 2025 - 11:55 UTC
Investigating
We're investigating reports from some clients seeing inaccurately displayed Mog Coin (Mog) balances in their account overview. The issue is limited to the visible balance and not reflective of their actual account balance. Please be assured that the security and safety of your funds are not affected by this temporary disruption.

We are working diligently to resolve the issue and will keep you informed. Thank you for your patience.
Posted Feb 02, 2025 - 21:51 UTC
This incident affected: Digital Currency Funding (Mog Coin (Mog) - ERC20).