Kraken Voice is unable to handle any inbound/outbound calls
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted May 19, 2023 - 02:52 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 19, 2023 - 00:54 UTC
Investigating
Kraken Voice is currently unable to handle any inbound/outbound calls due to technical issues.
Please reach out to us via InApp or Live Chat until the issue is resolved
Posted May 19, 2023 - 00:05 UTC