We continue to work on the full restoration of historical balance visibility. While the root cause has been identified and remediation is in progress, recovery is still ongoing and may take additional time to complete.
Posted Oct 13, 2025 - 12:15 UTC
Identified
We have identified the cause of the issue affecting historical balance visibility and are implementing a fix. The restoration process may take some time to complete. We will continue to provide updates as the restoration progresses.
Posted Oct 02, 2025 - 12:33 UTC
Investigating
We are currently investigating an issue affecting historical balance visibility. Some users may see missing or incorrect balance data for historical periods. Our engineering teams are actively investigating the issue. We will provide updates as more information becomes available.
Posted Oct 02, 2025 - 09:26 UTC
This incident affects: Website and Mobile Applications.