Degraded Performance - Historical Balance Display Across Multiple Platforms

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted May 28, 2025 - 11:29 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 28, 2025 - 10:00 UTC

Investigating

We are currently investigating an issue affecting historical balance visibility across multiple platforms. Users may experience increased latency or complete failure when attempting to view historical balances. Affected functionality includes: Kraken (Mobile & Web): historical balance chart may fail to load or respond slowly. Custody: vault balances may be unavailable. Embed clients: historical balances are not displayed. Our engineering teams are actively investigating the issue. We will provide updates as more information becomes available.
Posted May 28, 2025 - 09:56 UTC
This incident affected: Website, Mobile Applications and Kraken Custody (User Interface).