Issues with Credit Card Trades Displaying Errors

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Oct 02, 2025 - 17:23 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 02, 2025 - 16:16 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 02, 2025 - 14:15 UTC

Investigating

We are investigating an issue where some clients using Kraken mobile and web may see error messages when completing trades with a credit card. In most cases, the trades are successfully processed despite the error message. This may cause duplicate trade attempts. Kraken Pro is not impacted.
To avoid duplicate attempts, please check your portfolio before retrying a trade. Our engineering team is actively investigating the cause. We will provide updates as soon as more information becomes available.
Posted Oct 02, 2025 - 11:42 UTC