We are continuing to work on fix for this issue. It has been confirmed that a limited number of deposits across various assets may have experienced delays in processing between May 23–27.
Posted May 27, 2025 - 14:57 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 27, 2025 - 13:15 UTC
Investigating
We are currently investigating an issue where some deposits submitted on May 27th (UTC morning hours) may appear as successful but have not yet been credited to user balances. The issue affects multiple asset types, including Tether USD (USDT) – TRC20 (Tron). New deposits made after the impacted window are processing normally. Our engineering team is actively working to identify all affected transactions and implement a resolution.
Posted May 27, 2025 - 13:11 UTC
This incident affected: Digital Currency Funding (Tether USD (USDT) - TRC20).