Client Onboarding Delays

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Apr 10, 2026 - 10:32 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2026 - 10:24 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 10, 2026 - 09:40 UTC

Identified

We have identified an issue that is causing delays for clients attempting to onboard to Kraken. Our team are actively working to resolve the issue as soon as possible.
Posted Apr 10, 2026 - 09:34 UTC
This incident affected: Website, Kraken App, Kraken Pro App, Krak App and Kraken API (Embed).