Connection Issues
Incident Report for Kraken
Resolved
Connection Issues resolved. Website access is restored.
Posted Nov 13, 2017 - 09:18 UTC
Investigating
We are getting widespread reports that access to the website is either unavailable or unreliable. We are investigating and working to restore access.
Posted Nov 13, 2017 - 07:58 UTC