Zcash (ZEC) Funding
Incident Report for Kraken
Resolved
Maintenance has completed, and Zcash (ZEC) funding is now operational. Please accept our apologies for the delay.
Posted about 1 month ago. Apr 17, 2019 - 22:12 UTC
Identified
We are performing unexpected maintenance on our Zcash (ZEC) payment gateway. We expect this to be completed in approximately 30 minutes.
Posted about 1 month ago. Apr 17, 2019 - 20:29 UTC
This incident affected: Digital Currency Funding (ZCash (ZEC)).