Issues Completing MXN Deposits via SPEI

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 17:06 UTC

Investigating

We are currently investigating an issue affecting MXN deposits via SPEI. Clients attempting to fund their accounts using this method are not receiving deposit instructions and are unable to complete deposits. Our team is working to restore full service. We will provide an update as soon as more information is available.
Posted Oct 22, 2025 - 16:11 UTC
This incident affected: Payment Methods (Mexican Pesos (MXN) - Domestic).