Banking Circle Deposit Delays

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Jun 28, 2025 - 17:46 UTC

Identified

We are currently experiencing delays in crediting EUR and GBP deposits via Banking Circle due to scheduled maintenance. The maintenance is expected to conclude by 16:00 UTC. Withdrawals are not affected and continue to process normally. We will provide an update once the maintenance is completed and deposit processing resumes.
Posted Jun 28, 2025 - 15:03 UTC
This incident affected: Payment Methods (Euro (EUR) - Wire Transfer Deposits).