Delays with EUR Deposits via Revolut

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Sep 20, 2025 - 06:17 UTC

Investigating

We are currently investigating an issue affecting EUR deposits made via Revolut. Clients can still deposit EUR using alternative methods such as manual transfer via Banking Circle.

We apologize for the inconvenience and appreciate your patience.
Posted Sep 19, 2025 - 16:51 UTC
This incident affected: Payment Methods (Euro (EUR) - Instant).