EOS Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jan 16, 2020 - 17:50 UTC
Investigating
EOS deposits and withdrawals are currently delayed. We are investigating the issue and will provide any updates as soon as possible.
Posted Jan 16, 2020 - 16:39 UTC
This incident affected: Digital Currency Funding (EOS (EOS)).