Krak App Boost - USDG Conversion Failures

Incident Report for Kraken

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 25, 2025 - 22:28 UTC

Investigating

We are currently investigating an issue preventing some asset combinations from being converted to USDG using the Krak Boost feature.

Some users may see failures when attempting to complete a Boost conversion. There is no loss of funds and no incorrect charges. We are working diligently to resolve the issue and will keep you updated.
Posted Nov 25, 2025 - 13:46 UTC