Connectivity Issues - Pro Web, Account Settings, and Onboarding

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 11:32 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 11, 2025 - 08:47 UTC

Update

We are continuing to investigate this issue.
Posted Jun 11, 2025 - 08:41 UTC

Investigating

We are currently investigating multiple issues that may affect users: Difficulty connecting to Kraken Pro Web. Errors or delays when updating account settings (e.g., adding/removing 2FA, changing withdrawal permissions or wallet addresses), Failures during onboarding, including “Settings Locked” errors and incomplete setup steps. Some actions may appear to succeed but not take effect. Our teams are actively working to identify the root cause and restore full functionality.

We will provide further updates as soon as more information becomes available.
Posted Jun 11, 2025 - 08:37 UTC
This incident affected: Website, Mobile Applications and Kraken API (Embed).