BCB BLINC Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Dec 16, 2024 - 08:46 UTC
Identified
We've identified an issue with the BCB BLINC funding gateway. Deposits and withdrawals may be delayed at this time. All other funding methods are operating normally. We are working diligently to resolve the issue and will keep you updated.
Posted Dec 16, 2024 - 08:38 UTC
This incident affected: Payment Methods (Euro (EUR) - Wire Transfer Deposits, Pound Sterling (GBP) - Domestic).