THORchain (RUNE) Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Sep 27, 2024 - 10:46 UTC
Identified
The THORchain is currently halted, so RUNE funding (deposits and withdrawals) is delayed at this time. All other funding methods are operating normally. We are working diligently to resolve the issue and will keep you updated.
Posted Sep 27, 2024 - 10:28 UTC
This incident affected: Digital Currency Funding (THORchain (RUNE)).