Incorrect Balances Issue

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Sep 27, 2024 - 08:25 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 26, 2024 - 20:02 UTC

Investigating

We're investigating reports from clients seeing inaccurately displayed balances. We're currently working to resolve this issue and will provide updates as we're able.
Posted Sep 26, 2024 - 19:35 UTC
This incident affected: Website and Mobile Applications.