Stacks (STX) Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jan 30, 2024 - 23:55 UTC
Identified
We've identified an issue with the Stacks (STX) funding gateway. Deposits and withdrawals may be delayed at this time. All other funding methods are operating normally. We are working diligently to resolve the issue and will keep you updated.
Posted Jan 30, 2024 - 21:18 UTC
This incident affected: Digital Currency Funding (Stacks (STX)).