USD Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved and funding operations have been fully restored. Deposits and withdrawals are being processed normally. Thank you for your patience.
Posted Mar 27, 2020 - 04:50 UTC
Investigating
We are currently experiencing intermittent delays with domestic and international US Dollar (USD) deposits and withdrawals. We are investigating the issue and will provide an update as soon as we have further information.
Posted Mar 20, 2020 - 17:33 UTC
This incident affected: Fiat Currency Funding (US Dollar (USD) - Domestic, US Dollar (USD) - International).