USD Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Nov 29, 2019 - 18:42 UTC
Investigating
We are currently experiencing intermittent delays with Signature Domestic and International (USD) deposits and withdrawals. We are currently investigating the issue and will provide an update as soon as we have further information.
Posted Nov 29, 2019 - 16:20 UTC
This incident affected: Fiat Currency Funding (US Dollar (USD) - Domestic, US Dollar (USD) - International).