Verification Delays

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Jan 30, 2021 - 06:57 UTC

Update

We are continuing to investigate this issue.
Posted Jan 29, 2021 - 20:20 UTC

Update

We are continuing to investigate this issue.
Posted Jan 29, 2021 - 11:30 UTC

Investigating

Clients are unable to get verified. We are investigating the issue.
Posted Jan 29, 2021 - 06:59 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 29, 2021 - 06:37 UTC

Investigating

We are currently experiencing a heavy load of verification requests at kraken.com. We are investigating and looking into solutions to resolve this as soon as possible.

Uploaded documents are at the moment taking longer than usual to be processed.
Posted Jan 28, 2021 - 23:18 UTC
This incident affected: Website.