BRL Withdrawal Unavailable

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Jul 25, 2025 - 04:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 25, 2025 - 04:36 UTC

Investigating

We are investigating an issue with BRL withdrawals and withdrawal attempts. We are working diligently to resolve the issue and will keep you updated.
Posted Jul 25, 2025 - 03:49 UTC