Fidor Bank Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Nov 22, 2022 - 16:55 UTC
Update
We're investigating an issue with Fidor Bank funding. Deposits and withdrawals are currently not being processed. We will provide any updates as soon as possible.
Posted Nov 22, 2022 - 09:14 UTC
Investigating
We're investigating an issue with Fidor Bank funding. Deposits and withdrawals are currently delayed. We will provide any updates as soon as possible.
Posted Nov 19, 2022 - 00:38 UTC