Krak App - 30-day average balance issue

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted May 11, 2026 - 10:58 UTC

Identified

We are aware of an issue affecting the displaying of users' 30-day average balances, which may appear out of date. Our team has identified the issue and is preparing to implement a fix.
Posted May 10, 2026 - 19:25 UTC
This incident affected: Krak App.