Kraken Mobile App – Issues Converting or Selling Assets

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted May 20, 2025 - 18:03 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 20, 2025 - 17:33 UTC

Identified

We have identified that this issue is affecting users on older versions of the app (v3.15.x). If you are encountering this issue, please update to the latest version of the Kraken mobile app (v3.16).
Posted May 20, 2025 - 17:31 UTC

Investigating

We are currently investigating an issue affecting the Kraken Kraken Mobile App, where some clients are unable to convert or sell assets. The issue appears to be limited to the Kraken mobile app; web platform functionality remains unaffected. We will provide further updates as soon as more information is available.
Posted May 20, 2025 - 16:51 UTC
This incident affected: Mobile Applications.