Kraken Futures Website
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Dec 18, 2019 - 23:12 UTC
Monitoring
Our engineers have identified and implemented a fix for the issue. If you are still experiencing problems loading the page we recommend clearing your browser cache which we have a support article on here https://support.kraken.com/hc/en-us/articles/360001200183-Browser-troubleshooting

We will continue to monitor the site.
Posted Dec 18, 2019 - 06:42 UTC
Investigating
We are receiving reports of clients having intermittent issues loading the Kraken Futures site. We recommend refreshing the page multiple times in order to have the page load. Our engineers are aware of the issue and are working on resolving it. We will provide updates as necessary.
Posted Dec 18, 2019 - 02:14 UTC
This incident affected: Kraken Futures (Single Sign-On).