Portfolio Display Delays

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Sep 18, 2025 - 19:30 UTC

Investigating

We are currently investigating an issue affecting balance portfolio displays on Website, Mobile Applications and Kraken API (Embed).
Affected users may see delays and inconsistencies in getting portfolio values in the portfolio balance section.

We will provide an update as soon as more information is available. Thank you for your patience.
Posted Sep 18, 2025 - 16:55 UTC
This incident affected: Website, Mobile Applications and Kraken API (Embed).