Euro (EUR) - SEPA Withdrawal Issue
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted May 14, 2021 - 22:12 UTC
Update
We are investigating an issue with failing Euro (EUR) - SEPA withdrawals via Fidor. We recommend that clients that had their withdrawals fail use another SEPA method or try again until the transaction is processed. We have contacted Fidor IT support and they are currently investigating the issue. We will provide any updates as soon as possible.
Posted May 14, 2021 - 08:04 UTC
Investigating
We are investigating an issue with failing Euro (EUR) - SEPA withdrawals via Fidor. We recommend that clients that had their withdrawals fail use another SEPA method or try again until the transaction is processed. We have contacted Fidor IT support and they are currently investigating the issue. We will provide any updates as soon as possible.
Posted May 13, 2021 - 19:16 UTC
This incident affected: Payment Methods (Euro (EUR) - SEPA).