Krak App - degraded performance

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 12:48 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 30, 2026 - 12:15 UTC

Investigating

We are aware of an issue affecting some of the Krak App services. Some users may experience issues when viewing card details or completing certain card management actions, including card ordering.
Card payments using existing physical and virtual cards are not impacted and continue to function normally.

We will provide further updates as more information becomes available.
Posted Jul 30, 2026 - 12:02 UTC
This incident affected: Krak App.