Document Upload Issues
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jul 24, 2022 - 12:21 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 24, 2022 - 12:00 UTC
Investigating
We are investigating reports from some clients having difficulty creating new accounts or uploading documents to their account. We are working to resolve the issue and will update as soon as we have more information.
Posted Jul 24, 2022 - 10:29 UTC
This incident affected: Website.