Adding ACH accounts is failing on Consumer Android app (com.kraken.invest.app)

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 09:55 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 30, 2025 - 11:44 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 30, 2025 - 11:16 UTC

Investigating

We’re investigating an issue affecting users on the Consumer Android app (com.kraken.invest.app) who are unable to add new ACH bank accounts. Deposits from already-linked accounts are working as expected. Other platforms are unaffected and can be used as a workaround.

Our team is working to resolve the issue. We’ll post another update as soon as we have more information.
Posted Jun 30, 2025 - 09:01 UTC
This incident affected: Mobile Applications.