Fidor (EUR) Deposit Delays
Incident Report for Kraken
Resolved
The Fidor (EUR) deposits issue has been resolved, and deposit times have returned to normal.
Posted about 2 months ago. Dec 01, 2018 - 13:42 UTC
Investigating
Some clients have reported delays with Fidor (EUR) deposits. We are investigating the issue and will update as soon as we have more information.
Posted about 2 months ago. Nov 30, 2018 - 22:37 UTC
This incident affected: Fiat Currency Funding (Euro (EUR) - SEPA, Euro (EUR) - Wire Transfer Deposits).