USDG Trading Delay

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted May 11, 2026 - 03:56 UTC

Investigating

We are aware of an issue affecting USDG trading pairs. Trades involving USDG (other than USD/USDG swaps) are currently unavailable. Some users may also experience issues with USD/USDG swaps depending on the platform used. Our team is working to restore full functionality and we will provide an update shortly.
Posted May 11, 2026 - 02:15 UTC