Krak App Activity Log Issues

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 01:22 UTC

Investigating

Some users may experience issues receiving live updates on their Home Screen activity feed. As a temporary workaround, try minimizing or backgrounding the app and then reopening it. This will refresh your activity feed and update it with the latest information.
Posted Jul 10, 2025 - 01:10 UTC
This incident affected: Krak.