Krak Card degraded performance.

Incident Report for Kraken

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 22, 2026 - 15:52 UTC

Investigating

We are currently investigating an issue that causes transactions to show up with a delay in the activity feed.
Posted Sep 22, 2026 - 15:30 UTC
This incident affects: Krak Card.