Banking Circle - Funding Delays

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Jul 20, 2025 - 18:09 UTC

Identified

We’ve identified the issue as originating with our funding provider, Banking Circle, specifically through their Faster Payments Service (FPS). This may be impacting both deposits and withdrawals processed via Banking Circle UK EMI (FPS).

Our team is actively monitoring the situation and closely following the ongoing investigation being conducted by Banking Circle.
Posted Jul 20, 2025 - 03:15 UTC

Update

We are continuing to investigate this issue.
Posted Jul 20, 2025 - 01:11 UTC

Investigating

We're investigating reports regarding the Banking Circle funding gateway. Deposits may be delayed at this time for GBP via Faster Payment Services. All other funding methods, including withdrawals through Banking Circle, are operating normally. We are working diligently to resolve the issue and will keep you updated.
Posted Jul 20, 2025 - 01:10 UTC
This incident affected: Payment Methods (Euro (EUR) - Instant, Euro (EUR) - SEPA, Pound Sterling (GBP) - Domestic, Pound Sterling (GBP) - Instant).